SubversionInEase

From CT Wiki
Jump to: navigation, search

Contents

Enabling Subversion support in Ease

Ease is an HDL Entry tool by HDL Works (http://www.hdlworks.com). It is currently used by the ET group for design and verfication purposes.

It is possible to add versioning to an Ease project, using either CVS or Subversion. This page explains how to set up Subversion versioning support for both EASE on Linux and EASE on Windows.

Ease on Linux

For this tutorial EASE v7.4rev9 on Linux was used. A newer version is available (see the Windows section below) but here an older version is used to show that it also supports Subversion versioning.

Enable Subversion support

First, if you have not already done so, configure Subversion support in Ease:

  • Go to menu Options->User Options
  • Click on the item Versioning in the list on the left. A new window will pop up:

Etsvn-ease7l-setup-svn.png

  • Enable the tick mark in front of 'Configure for Subversion support'
  • Click 'OK'

Start or load a project

Now, make sure a project is loaded or start a new project. If not, then the required menu option for setting up Subversion access is not enabled (You don't want to ask how long it took to figure this one out).

  • Once a project is loaded, the menu option File->Subversion->Create Project should now be available. Choose this option. Ease will now ask you which Subversion repository to use for your new project. If you need to set up a new Subversion repository, then do that first. See Setting up a new Subversion repository for details.
  • For the Subversion repository, fill in
 svn+ssh://etsvn@svn.nikhef.nl/<NameOfSvnRepo>

and choose a name for your project (in the screenshot below NewProject was chosen):

Note: Do not add a slash at the end of the Subversion repository path, as both Ease 7 and Ease 8 will coredump with

 ease: subversion/libsvn_subr/path.c:368: svn_path_dirname: Assertion `svn_path_is_canonical(path, pool)' failed.
 Aborted (core dumped)

Etsvn-ease7l-new-project.png

  • Ease will now set up the necessary files in the Subversion project. If all goes well it will ask for the name of the workspace to save the project in:

Etsvn-ease7l-create-workspace.png

  • Once the project is set up and saved the status window will show the following message:

Etsvn-ease7l-project-saved.png

Checking the status

You can verify that an Ease project is managed using Subversion by looking at the window title bar and by hovering over the project name:

Etsvn-ease7l-project-status.png

Ease on Windows

For this tutorial EASE v8.0rev8 on Windows XP was used. A newer version of Windows should be used, of course, but here an older version is used to show that it can also support Subversion versioning.

Enable Subversion support

First, if you have not already done so, configure Subversion support in Ease:

  • Go to menu Options->User Options
  • Click on the item Versioning in the list on the left. A new window will pop up:

Etsvn-ease8w-setup-svn.png

  • Enable the tick mark in front of 'Configure for Subversion support'
  • Click 'OK'

Start or load a project

Now, make sure a project is loaded or start a new project. If not, then the required menu option for setting up Subversion access is not enabled (You don't want to ask how long it took to figure this one out).

  • Once a project is loaded, the menu option File->Subversion->Create Project should now be available. Choose this option. Ease will now ask you which Subversion repository to use for your new project. If you need to set up a new Subversion repository, then do that first. See Setting up a new Subversion repository for details.
  • For the Subversion repository, fill in
 svn+ssh://etsvn@svn.nikhef.nl/<NameOfSvnRepo>

and choose a name for your project (in the screenshot below MyWinProject was chosen):

Note: Do not add a slash at the end of the Subversion repository path

Etsvn-ease8w-new-project.png

  • Ease will now set up the necessary files in the Subversion project. If all goes well it will ask for the name of the workspace to save the project in:

Etsvn-ease8w-create-workspace.png

  • Once the project is set up and saved the status window will show the following message in the console part of the screen:

Etsvn-ease8w-project-saved.png

Checking the status

You can verify that an Ease project is managed using Subversion by looking at the window title bar and by hovering over the project name:

Etsvn-ease8w-project-saved.png

(Yes, this is the same screenshot as the previous one :))

Troubleshooting

Troubleshooting Subversion support in Ease can be quite a hassle. Here's a list of things to try:

  • first check that (passwordless) svn access is working. See the main Subversion pages for details
  • launch Ease from a terminal or console window. Check for any messages on this console window when trying to create a new Subversion project
  • On Windows, check how many plink.exe processes are running. If this number is high (or increasing) then most likely there's a problem with either the PuTTY link and/or with the commandline svn tools.
Views
Personal tools